Home Forums Unreal Tournament 2004 UT2004 Competition Settings: The Basics


This topic contains 21 replies, has 10 voices, and was last updated by asc asc 3 years, 11 months ago.

Viewing 7 posts - 16 through 22 (of 22 total)
  • Author
  • #232


    Quite informative!

    I wanted to know if there is a way to force the model, even if there is no utcomp on server.

    Well, i would like to force it to gorge ideally. If you happen to know how (or if it’s even possible), let me know =) , ty in advance.

    In your UT2004.ini change this:


    In your User.ini change these:


    It only works if you choose Gorge as your own player model. So:



    <div class=”d4p-bbt-quote-title”>Pyth0n wrote:</div>
    I play with a stable 250fps at a 120hz monitor, netspeed 12500. 2 frames per hz, and a few bonus :)<br><br>
    (Netspeed 100001 is enough to unlock the fps-cap, yet I figure it’s too low when reaching these higher fps)

    A while back I did use 125fps at the very same 120hz monitor,<br><br>
    but once I tried to double up the fps I will never go back.<br><br>
    There’s a big difference in the overall smoothness of how the game perform!

    When I tried 256fps I also noticed a lot of warping with my movement, even without any registered packet-loss. It was unplayable. I even noticed the odd warping at 200fps, however 170fps was perfectly fine.

    I find that the lowest Netspeed to make the jump from 200fps to 256fps starts from ‘Netspeed=10501′. I don’t know why everyone has come up with different Netspeed answers, you should double check that the server has registered your Netspeed change by pressing F6 or typing ‘net stat’ in console.

    I did a bit of reading and testing, and found that I was wrong about Netspeed.

    Apparently Netspeed is the number of bytes you want to send/receive. One update is worth 64 bytes. So with 170fps your Netspeed= 170 * 64 = 10880. Also, 205fps = 13120 Netspeed, and 260fps = 16640 Netspeed.

    So, that bit about 256fps being unplayable was because of the Netspeed being too low. Netspeed 10501 may have been enough to unlock the 256fps cap but the game was dropping some data before sending it. When Netspeed was set to 16640 the game was playable again.

    Currently the game only sends half your frame-rate data in packets meaning that other half is wasted, BUT I found that there’s a way to send the same number packets as the your frame-rate:

    KeepAliveTime=0.00 #default=0.2

    Doing this will mean you’re uploading your status constantly. It should feel more responsive. You’ll be sending more data though, so if you had 205fps you’ll be sending up to 13,120KB/s which shouldn’t be a problem on current connections. Look out for packet-loss though.

    There is a problem with using 256fps as it requires servers’ Netspeed to be above the default setting of 15000 to be completely smooth. I find that 205fps is still not completely stable, so I’m sticking to 170fps for the moment.

    Hopefully this clears things up. That KeepAliveTime finding could be quite an important thing to change. This game is almost ten years old yet we still don’t fully understand it. :)

    EDIT: KeepAliveTime=0.000 may not be the best idea, check: UT2004 Max FPS & Connection Settings Guide



    @nMs: thank you, sir!


    Nice guide, will test some settings. :)

    • This reply was modified 4 years, 10 months ago by krav1nho krav1nho.


    If anyone is interested, I have uploaded my ini’s:

    >>>> NmS- config files <<<<

    Some stuff I did:

    • Made for 120Hz monitor refreshrate (CRT ftw!)
    • MaxClientFrameRate=130, trying to sync it as close as possible with my monitors Hz to get smooth graphics.
    • Lowered sound volume for TDM config, to hear TS communication better.
    • Set the user.ini to read-only in windows, so that UT2004 doesn’t add or change any settings without my knowledge
    • Categorized all the keybinds (easier to find what I want to change)
    • Removed all common alliases and using the raw commands instead (less delay)
    • Removed unneeded stuff from the user.ini, like singleplayer settings and crap, making the filesize smaller (makes everything run smooth and quick)
    • Made different profiles that can be executed (User.ADMIN, User.DUEL, User.TDM, User.TAM). Each having their own unique settings for the same keys. ( I ran out of keys :P)
    • Binded every weapon to its own key on the keyboard
    • Disabled auto switch on pickup
    • Disabled Bob
    • Disabled WeaponBob
    • Disabled Coronas
    • Disabled Loading screens
    • Disabled own footstep sounds
    • Lowered sound volume of minigun, linkgun and shield-gun
    • Set all player skins to Gorge (M) and Rylissa (F)
    • Set demomask to %d-(%t)-%m-%p (date-time-map-playername)
    • Set screenshotmask to %d-(%c)-%m-%p (date-count-map-playername)
    • Set mouse settings to suite my own style (24cm/360 degrees, no mouse accel or smoothing)
    • Set custom crosshair I ported from TTM UT2003 (colored dot with black around it)
    • Set brightskins for utcomp and TAM to bright pink (enemy) and bright green (friend)
    • Set the ut2004.ini to read-only in windows, so that UT2004 doesn’t add or change any settings without my knowledge
    • Disabled Music and Ambient sounds (makes you hear the enemy’s footsteps and jump sounds better across the map)
    • Set Rolloff to 0.400000 (makes you hear the enemy’s footsteps and jump sounds better across the map).
    • All graphical settings to their lowest value
    • Enabled TripleBuffering (smoother FPS)
    • Disabled WeaponShake
    • Making screen darker while keeping contrast high (gives dark map with very bright player skins, making you see enemy better)
    • Adjusted brightness, gamma and contrast so I can still see details in dark corners
    • Some minor stuff

    Those other files change the following Open them in notepad to see what the values are.

    Changed the pickup messages of shield, health, etc

    Changed some of the weapon names and pickups
    Changed some of the ammo pickups
    Changed deathconsole messages to NmS- | Rocket | ScrMz! or Frantic- | Bio-Rifle | NmS-

    Changed headshot message
    Changed killing spree messages to:
    - “2x K1LL!!”
    - “Mult1 <3″
    - “Mega K1ll!!”
    - “ULTRA K1LL!!”
    - “M O N S T E R K 1 L L !!!”
    - “O R G A S M I C !!!”
    - “C H E A T E R !!!”

    User.DUEL, User.TDM, User.TAM
    Three different profiles with some settings for each gametype. Nothing fancy atm, but I might add some more stuff to that in the future

    Needed this to fix teamsay in combination with throwweapon. Wouldn’t work otherwise

    Config to load for admin commands.

    • This reply was modified 4 years, 10 months ago by  NmS-.
    • This reply was modified 4 years, 10 months ago by  NmS-.
    • This reply was modified 4 years, 10 months ago by  NmS-.


    Just wanted to say thanks to asc for all his research and incredibly informative guides! This is awesome stuff and a great reference point for anyone wanting to learn :)

    If this is a double post then I apologise but I tried to post this once already and it seemed to have been devoured.

    With regard to ReduceMouseLag I think this is a subjective preference. For example I have it set to ‘True’ because when it was False, I was having some difficulties with reaction shots when testing on an iCTF public server. With it set to false, the mouse movement does actually feel better, but slightly delayed – I prefer the more responsive feel and because it’s under the rendering device section in the ini instead of under the input, it makes me feel that it’s not causing any interpolation. Of course I am not a developer nor am I familiar with UE2/3/4 so I couldn’t say what it does for certain.

    However reading all this did prompt me to start digging around and see what I could find (as it’s literally been years since I looked into tweaks and admin commands etc) and I stumbled across something in the User.ini under Engine.Input:

    MouseX=Count bXAxis | Axis aMouseX Speed=2.0
    MouseY=Count bYAxis | Axis aMouseY Speed=2.0

    Now I’ve had these as 1.0 for ages since intuitively it seemed a little suspicious to me (why would you count 2? won’t that make it less accurate?) but I was in the mood for experimentation.

    Plus on the UE4 forums I read something about older versions of Unreal Engine where if the mouse sensitivity value wasn’t an integer then it would be less accurate.

    So as an experiment today I set both the count values to 0.125 and upped my sens to a whole number, and it actually made a huge difference to how the mouse feels. While it is technically the “same” sens in terms of cm/360, the movement feels a lot smoother and “finer” I guess you could call it. It feels as though it registers slow, small mouse movements much more accurately. Like I always had problems sometimes with shock and flak primary, where it felt like I had to ‘flick’ many shots, especially with flak, because if I moved the mouse more slowly and smoothly, the crosshair would be ‘stuck’ and wouldn’t move – but it feels more responsive this way.

    I suppose it’s a similar principle to changing m_pitch and m_yaw to a lower value (eg 0.001) from 0.022 in Quake engine games – something I also tried with similar results. Interesting that in CoD4 promod or certain punkbuster servers they actually disallow the use of values below and including 0.015.

    I guess this is all a little moot now that UT4 is around the corner and it appears to be written very differently, but I was a little bored and felt like I’d leave this here in case anyone wants to experiment. :p


    I think that ‘ReduceMouseLag’ is the same as having ‘Max pre-rendered frames (Nvidia)’ or ‘Flip Queue Size (AMD)’ set to 1 or 0. Since I had it set as 0 via the RadeonPro app, I noticed no effect upon turning it off/on in-game. The FPS hit is too large with it on, and I prefer the higher FPS cap that’s stable than having a low FPS cap with it on.

    MouseX=Count bXAxis | Axis aMouseX Speed=2.0
    MouseY=Count bYAxis | Axis aMouseY Speed=2.0

    I’d be careful of changing this as it relates to your mouse DPI value. Try fully zooming in with the LG and make slow mouse movements to see if it registers or not.
    The weird thing I noticed was that with my mouse DPI set at default – 1000, and Axis aMouseX Speed=1.0, then it would not register zoomed in slow movements, however if I dropped the DPI to 500 and set Axis aMouseX Speed=2.0, then it would register. This being at the same cm/360 sens.

    FPS related — I found that UT2004 doesn’t really like quad-core processors, and so I made a bat file that makes it only use dual cores. It resulted in a higher and more stable frame-rate.
    To do this, make a new text file and add this line and edit the correct path:
    start /High /affinity 3 D:\UT2004\System\UT2004.exe
    Save as .bat
    Same can be done for the 64-bit UT2004 executable. The ‘/High’ makes the game run at a higher priority. You can change this to ‘/AboveNormal’ if it’s too much.

Viewing 7 posts - 16 through 22 (of 22 total)

You must be logged in to reply to this topic.